Cayman National

Secure Web Connections

As part of our ongoing efforts to align ourselves with the best security practices, we will be making changes to ensure that connections to our Website meet the highest security standards. These changes will be done on 30 June, 2018 and will impact customers trying to connect with browsers that do not support TLS 1.2.

You can test your browser’s compatibility with TLS 1.2 by launching https://www.ssllabs.com/ssltest/viewMyClient.html. If your browser does not meet compatibility requirements, we suggest that you upgrade to a newer version. You can find a list of compatible browsers and versions here.

If you have any questions, please feel free to contact us at 345 949 4655.